Why hasn't my blog been indexed yet?
2015-01-31, 11:13 PM,
#1
About a month ago I started writing a blog which i plan to be like a website rather than a blog. On the 19th I finished all the pages, but I'm still adding content to the posts so I get the right keyword density. I saw that my page hasn't been indexed, so yesterday I used a sitemap generating tool and implemented it on my blog. Today, not even one post is indexed, and in Webmaster tools it says that they haven't detected any structured data on my site. Do I need to add HTML Markup on my pages, or is there another problem? You have to forgive me I am new at this and any help and info would be much appreciated.
Reply
2015-01-31, 11:31 PM,
#2
What platform are you using? WordPress, hand made HTML site etc.

Your site is not indexed because googlebot probably haven't even visited it yet.

Other problem might be duplicate/crappy content.

Sitemaps work in 2 steps.
1. Sitemap generation
2. Submission

Are you sure you submitted it, not just generated? You can do this through webmaster tools fe.

Sitemap is useless if search engines don't know it exists.

Other problem might be simply wrong method of index checking. Always use site:yourdomain.com search parameter to be sure.

I take it you have a static homepage right? Is so, you can fix this easily by using video sitemap instead of regular one.


This is a short tutorial for WordPress:

1. Install this plugin (exact name): Google XML Sitemap for Videos
2. Embed YouTube video to your homepage and 2 posts (3 different topic related videos)
3. Submit your video sitemap (it's under Tools in WordPress)
Reply
2015-01-31, 11:47 PM,
#3
I'm using blogger for my blog. The content is somewhat crappy, that's why I'm adding more content to my posts. I have generated the sitemap and submitted it in webmaster tools, also I pasted the generated text in the custom robots.txt. I also added both versions of my site, with www and without. I added a sitemap on both of them. Yes, I've made a static homepage before. In webmaster tools, the search queries show some information of impressions and clicks, it says there are no crawl errors, but in the sitemaps section, it only shows submitted URLs (94 to be more exact) , and doesn't show any indexed ones.
Reply
2015-02-01, 02:36 AM,
#4
Is this your first time you are trying to index this site?

Was the site indexed at some point in the past?

What what I know so far it possible issues might be low quality content and/or robots.txt conflict since blogger creates your own sitemap and robots.txt by default so your manual changes might confuse it.

Other option is incorrect DNS setup.

Use this tool to see any errors and if your site points to correct nameservers:

http://www.intodns.com/


tiiberius
Reply
2015-02-01, 04:58 AM,
#5
The page hasn't been indexed before, I'm not sure about the robots.txt, but even with the old settings, the blog hasn't been indexed. I've tried the tool you provided, but sadly it doesn't work for subdomains. It says it's still in beta. However, i tried another tool to check DNS and it says: "No delegation could be found at the parent, making your zone unreachable from the Internet." "Not enough nameserver information was found to test the zone, but an IP address lookup succeeded in spite of that."
Reply
2015-02-01, 04:56 PM,
#6
The confusion I think you are having here is that the check you are performing is for a zone and not for a record.

IP address lookup succeeded so record should be fine but zone doesn't exist so you get the error message.

Also, that part where you talk about www and non-www version is quite confusing since blogger doesn't allow you to work with that with default subdomain they give you (as far as I'm concerned). You would need custom domain name (the one you buy) for it.

So just to be clear...

Do you use custom domain name (http://www.something.com) or Blogger's default one (something.blogspot.com) ?
Reply
2015-02-01, 10:05 PM,
#7
I'm using blogger's default domain name. When I added the non-www version of the page on webmaster tools, it showed some results of activity on my page. Now I checked and it shows that almost all my URLs are indexed, but I still get the message about the structured data. Do I need to add HTML markup?
Reply
2015-02-01, 10:29 PM,
#8
Good job getting your site indexed.

Well, if you are getting that message structured data are probably not present. It might be an error tho but probably not.

Yes, go ahead and add them. They help search engines to understand your website better and therefore giving you a slight boost in SERPs

Use this tool along the way to check if you are doing things correctly:
http://www.google.com/webmasters/tools/richsnippets
Latest Thanks - View all

PHz(2015-02-02 12:34 AM) 
Reply
2015-02-02, 12:36 AM,
#9
Thanks, friend :) You've been of much help. Nice to see there are people who are willing to share their knowledge.
Reply
2015-02-02, 12:59 AM,
#10
Sure thing no problem ;)
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Blog Commenting is helpful to get the backlinks? samuelroy 8 443 2017-10-16, 05:32 PM
Last Post: andreausa
  [method] of Indexing any Webpage/Blog Post Instantly in Google (100% Working) ÐExTeR 63 9,548 2017-10-14, 06:16 AM
Last Post: imronrosyadi
  The Worst Misconception About Blog Posts You Probably Believe In! LB'Decoy 21 620 2017-10-14, 12:44 AM
Last Post: ougasoft
  Untapped Backlink Sources (No Guest Posts & Blog Comments) LB'Decoy 15 637 2017-10-13, 10:47 AM
Last Post: KentVMason
  Best Blog to Rank in Google pioter7 8 394 2017-09-18, 11:59 AM
Last Post: samuelroy




About Us | Contact Us | CPA Elites | Advertise | Stats | Staff Team

© 2013-2017 CPA Elites Ltd
Enhanced by MyBB and WallBB
Return to top