[Help] What am i doing wrong ?
2013-11-08, 11:12 PM,
#1
Hi guys,

I uploaded various niches, black and whites, all that stuff really good "packed", i made some good videos, good landing page, i also sent really good views/likes/subscribes on the video ...
BUT!
Still video lost in youtube pages, not even close to page one.

What am i missing ?
What am i doing wrong ?

If any1 wanna help a newbie, it would be awesome

Tnx, NW
Reply
2013-11-08, 11:13 PM,
#2
How about HR views, likes, comments, favourites, subscribers?
And you set up ON-site SEO?
Latest Thanks - View all

Nightwatch(2013-11-10 08:22 AM) 

Please quote me if you are replying to me so I would get a notification.

Get Youtube likes/views, SEO backlinks for only $5. Meet fiverr.

Get everything you need for Internet marketing! Meet SeoClerks.

Thanks for using my affiliate links Smile
Reply
2013-11-08, 11:18 PM,
(This post was last modified: 2013-11-08, 11:18 PM by Nightwatch.)
#3
I think that the views are HR, but still kinda amateur on setting up SEO's.
Reply
2013-11-10, 08:23 AM,
#4
Today i got my first 2 downloads, tnx to adding some SEO on my links.
Big thanks to you hibr3d, hopefully the number will go higher
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  No conversion, what is wrong with my methods? paja93 14 674 2017-09-01, 07:00 PM
Last Post: Ana_AdCombo
  Facebook Ad gone wrong (what am i doing wrong) dontbejello87 2 171 2017-07-21, 10:24 AM
Last Post: iBrobot
  What im i doing wrong? IG+FL f1rew1re 7 343 2017-07-01, 04:35 PM
Last Post: xujambambam
  What's wrong with CPALead? zilvis89 14 1,144 2017-05-11, 11:57 PM
Last Post: Fasmartsdv
  WHAT AM I DOING WRONG?! cubruh 5 353 2017-04-21, 06:31 AM
Last Post: cubruh




About Us | Contact Us | CPA Elites | Advertise | Stats | Staff Team

© 2013-2017 CPA Elites Ltd
Enhanced by MyBB and WallBB
Return to top