Deindexing www version of site and indexing naked version
2015-03-14, 11:20 PM,
#1
I feel like pulling my hair out right now from this

So I created my website and indexed it with google webmasters. The naked version was indexed which is exactly what I wanted. After messing with the setting I saw you could set a preferred version so I thought I would set it to the naked version just to be safe and so that the www version never gets indexed. Well I got an error message saying I would need to add the www version of my site to my webmasters account to do that. I figured why not? So I add the www version of my site to webmasters and set the naked version as the preferred version on both.

Everything is going fine for about three weeks, all my internal links on the site are the naked version and google has the naked version of my site indexed which is what I want. I start getting backlinks built for a specific webpage and start checking it in ahrefs and after it hit around a couple thousand backlinks I started checking the search results for it. What I saw was half of my links were www and the other have were the naked version. The specific page that the links were built to had the www version indexed but I built all the links for the naked version.

I figured it would clear itself up since I selected the preferred version after a few days and figured this was normal. Nope, after a week things stayed the same. I went to yahoo and bing and both have the naked version indexed and my webpage is ranking very well on both for my keywords. I started trying to manually get google to index the naked version by consistently submitting new sitemaps, doing fetches as google, and submitted links to their index and nothing changed.

So a few days ago I got in webmasters and requested removal of all www versions from the index. I figured if they got de-indexed then the naked versions would get indexed. I did fetches as google, sitemaps, submitted links to google for three days for the naked version and nothing. Actually neither the www or the naked version was indexed anymore. So I reverted the changes so my site would be in the google index and hopefully would use the naked version since its already set as preferred.

But this morning I woke up to the same thing, half www and half naked. What do I do?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Track YouTube Video Rank Manually+Useful Site Watt 25 1,169 9 hours ago
Last Post: Watt
  Multiniche or single niche site for CPA? Project_Leader 11 535 2017-10-03, 12:28 AM
Last Post: fateha
  (Question) How to handle content locker for wordpress site with multiple posts ZohnSon 4 209 2017-09-27, 09:53 PM
Last Post: ZohnSon
  Multi niche site opinions ? verton 8 206 2017-09-04, 12:03 AM
Last Post: verton
  Question about a single niche site Project_Leader 10 259 2017-08-28, 05:20 PM
Last Post: botmaker111




About Us | Contact Us | CPA Elites | Advertise | Stats | Staff Team

© 2013-2017 CPA Elites Ltd
Enhanced by MyBB and WallBB
Return to top